Espace privé

Si vous souhaitez créer un profil pour ce site, merci de m'envoyer votre Mél et votre pseudo en remplissant le formulaire joint.

Mes plugins

Fermer editoPlus

Fermer Sesame

Fermer infoPratique

Fermer twitterLink

Fermer Fork modo-1

Fermer formulaire

Fermer Docuthèque

Fermer CPLcommun

Fermer FORK cplMailBatch

Site de test

Vous pouvez tester mes plugins (y compris la partie admin) sur mon site de test.

Divers
Recherche



Lettre d'information
Pour avoir des nouvelles de ce site, inscrivez-vous à notre Lettre d'information.
Captcha
Recopier le code :
35 Abonnés
RSS
Visites

   visiteurs

   visiteurs en ligne

C'est ici que je vis

France

Département de l'HéraultPouzols

Archives
Lien twitter
forum - plugin docuthèque - Sujet n°157

La Charte du Forum - La Charte du Forum

forum - forum
plugin docuthèque - plugin docuthèque


actif  Sujet n° 157  Message d'erreur

le 04/08/2015 - 13h39
par alpha26

Anonyme

visiteur

Bonjour,
Après installation, configuration et création des répertoires, catégories et dossiers, j'ai ajouté un fichier dans un dossier et ajouté la boite Docuthèque sur mon site.
A la place de la boite un message d'erreur s'affiche :
Fatal error: Call to undefined function dct_fbox() in /htdocs/blog/inc/functions.php on line 2129
Pouvez-vous me donner une explication et une solution ?
J'utilise Guppy 5 avec Docuthèque 4.6.3 et le CPLCommun 8.0
Merci de votre aide.
Cordialement
Ecrire à alpha26   Poster une réponse  Haut

[]   

Réponse n° 1
--------
le 05/08/2015 - 21h00
par tonton_christian

tonton_christian

Administrateur
333 messages

Bonsoir

Oui, j'ai une explication: le plugin n'est pas compatible avec la V5 de GuppY.

Non, je n'ai pas de solution, voir la FAQ (ici).

Si vous tenez absolument à utiliser ce plugin, vous pouvez installer un guppy secondaire en v4.6.28 que vous appelez dans une iframe. Il faut modifier un script pour que guppy s'exécute dans une iframe.


Réfléchis bien ... avant!

Ecrire à tonton_christian   Site web tonton_christian Poster une réponse  Haut
Réponse n° 2
--------
le 06/08/2015 - 06h25
par alpha26

Anonyme

visiteur
Bonjour,

Merci pour votre réponse qui explique tout.

Je ne vois nul part indiqué que cette version n'est pas compatible avec Guppy 5, bien au contraire dans la présentation, les notices administratives du plugin et en particulier dans le CPLcommun il est bien indiqué la compatibilité avec la version 5.

Pouvez-vous m'expliquer comment modifier le script pour que Guppy 4.6.28 puisse s'exécuter en iframe ?

Bien cordialement,
Alain
Ecrire à alpha26   Poster une réponse  Haut
Réponse n° 3
--------
le 06/08/2015 - 15h22
par tonton_christian

tonton_christian

Administrateur
334 messages
Vous avez raison il n'est pas écrit que cette version n'est pas compatible avec GuppY 5. Mais il n'est pas écrit non plus qu'elle l'est e. Pour tous les plugins il y a un article (ici) intitulé "version" et il est clairement dit que c'est compatible avec la version 4.6.28 de GuppY.

Dans le téléchargement de CPLcommun V8.0 j'ai indiqué que c'était une version compatible V5 et V4 mais que pour l'instant les autres plugins n'était qu'en V4. D'ailleurs pour la V8.1, je n'ai même pas testé en V5.
 
De plus dans l'administration de CPLcommun, il y a un tableau des compatibilités avec une colonnes pour les versions de GuppY et il y a un gros sens interdit dans la colonne V5 pour tous les plusgins.

Pour supprimer le contrôle iframe, c'est dans le script inc/hpage.js, vous recherchez les lignes (normalement N°14)
Code : javascript
if (window!=top) {
top.location=window.location;
}
Vous les commentez (c'est mieux que de les supprimer pour pouvoir revenir en arrière) . Je vous invite toutefois à consulter les archives du forum sur freeguppy (http://www.freeguppy.org/threadarch.php?lng=fr&pg=254695) car c'est une opération pas orthodoxe; JeandePeyrat indique qu'il y a des problèmes mais sans quan même les citer!


Réfléchis bien ... avant!

Ecrire à tonton_christian   Site web tonton_christian Poster une réponse  Haut
Réponse n° 4
--------
le 06/08/2015 - 17h42
par alpha26

Anonyme

visiteur
Je ne trouve pas la version 8.1 de CPLcommun en téléchargement sur votre site.

La partie administration de CPLcommun sur mon site n'indique absolument rien si ce n'est qu'il y a une erreur et que je dois contacter l'administrateur pour régler le problème avec le lien de votre site.

Je vous remercie pour vos explications en ce qui concerne l'iframe mais je crois que je vais rester sage et malheureusement me passer de Docuthèque qui aurait pu me rendre bien des services . . .

Je suis désolé de ne pas avoir été assez vigilant sur les explications que vous fournissez au sujet de Docuthèque et des autres plugins, vous avez raison c'est bien noté au niveau de la compatibilité.
Pensez-vous mettre à jour vos plugins pour une compatibilité avec Guppy 5 ?
Car même si cette nouvelle version offre bien des services supplémentaires et nouveaux je trouve que vos plugins peuvent être tout autant intéressants suivant ce qu'on désire obtenir sur un site et en fonction de nos projets.

J'administre un site littéraire qui pointe en particulier le domaine de la poésie et de tous les ouvrages liés et il se trouve que j'aurais aimé installer un plugin permettant de gérer une bibliothèque où il serait possible d'ajouter des livres avec présentation de couverture, résumé, présentation auteur et liens.
Si jamais vous connaissez un plugin permettant cela j'en serais ravi . . .

Merci encore de vos réponses claires et rapides, c'est appréciable !
Bien cordialement,
Alain
Ecrire à alpha26   Poster une réponse  Haut
Réponse n° 5
--------
le 06/08/2015 - 19h46
par tonton_christian

tonton_christian

Administrateur
335 messages
Citation : alpha26

Je ne trouve pas la version 8.1 de CPLcommun en téléchargement sur votre site.

 
Effectivement elle est en test et je ne l'est pas rendue publique.

Elle n'a d'intérêt que pour une nouvelle version d'editoPlus (4.6.4) en test elle aussi. IL faut un identifiant  pour la voir.

 
Citation : alpha26

La partie administration de CPLcommun sur mon site n'indique absolument rien si ce n'est qu'il y a une erreur et que je dois contacter l'administrateur pour régler le problème avec le lien de votre site.


est-vous chez free?

 
Citation : alpha26

Pensez-vous mettre à jour vos plugins pour une compatibilité avec Guppy 5 ?

 
il me semble être clair dans la FAQ. je préfère consacrer le peu d'énergie qui me reste à ajouter des fonctionnalités aux plugins qu'à courir après la succession des versions de GuppY. Avec GuppY V4, editoPlus, Sesame, et Docuthèque, j'ai fait un mini groupware (informatique de groupe) adapté aux associations. Il manque encore des choses mais ça commence à servir. Peut-être que lorsque j'aurais atteint un palier, je m'attaquerai à la conversion, mais c'est pas demain la veille. 

 
Citation : alpha26

Si jamais vous connaissez un plugin permettant cela j'en serais ravi . . .

 
non, il faut regarder sur guppyland


Réfléchis bien ... avant!

Ecrire à tonton_christian   Site web tonton_christian Poster une réponse  Haut
Réponse n° 6
--------
le 07/08/2015 - 06h28
par alpha26

Anonyme

visiteur
Merci d'avoir pris le temps de répondre à mes questions.

Décidément je ne lis pas correctement vos explications sur le site et j'ai bien compris qu'il fallait être inscrit pour voir cette version de CPLcommun.

Oui je suis chez Free. . .

Je comprends votre position en ce qui concerne les mises à jour des plugins c'est effectivement plus important d'améliorer pour répondre aux besoins mais toutefois c'est important aussi de pouvoir se servir des plugins avec toutes les versions de Guppy puisque ça favorise leur évolution et leurs utilisations auprès d'un plus grand nombre de sites.

J'ai déjà regardé sur Guppyland mais rien ne correspond vraiment à mes attentes et il y a bon nombre de plugins pour les versions antérieures mais très peu pour la dernière version. . ..
Ecrire à alpha26   Poster une réponse  Haut
Réponse n° 7
--------
le 07/08/2015 - 09h15
par tonton_christian

tonton_christian

Administrateur
336 messages
Citation : alpha26

c'est important aussi de pouvoir se servir des plugins avec toutes les versions de Guppy

 
je suis d'accord; donc quand on fait un cms on fait en sorte que l'interface des plugins soit constant et on n'oblige pas les concepteurs de plugins à les réécrire lors d'une montée de version.

si vous êtes chez free, c'est normal ils interdisent d'interroger des sites externes; or le tableau que j'affiche est extérieur (pour des raisons de mise à jour en temps réel).


Réfléchis bien ... avant!

Ecrire à tonton_christian   Site web tonton_christian Poster une réponse  Haut
Réponse n° 8
--------
le 07/08/2015 - 09h55
par alpha26

Anonyme

visiteur
Oui je suis bien d'accord avec vous mais c'est malheureusement les déboires que rencontrent de nombreux concepteurs dans bien des domaines et toujours pour au final une histoire de gros sous . . .comme Microsoft  au hasard lol

 Ah d'accord pour le tableau CPLcommun, je savais que chez Free il y avait quelques contraintes . . .

Je vous remercie d'avoir répondu présent dans mes messages et je vous souhaite bonne continuation dans vos investigations pluginales.

Bien cordialement,
Alain
Ecrire à alpha26   Poster une réponse  Haut
actif sujet actif   clos sujet clos   Important! Important!   Nouveau Nouveau message   -   Rectifier Rectifier message   Clôturer Clôturer sujet   Remonter Remonter
[]
Catégories de discussion  forum 




^ Haut ^